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M2M's software modem allows remote Uploading & Downloading from panels.
It helps the installers to perform configuration changes or download the event history of the panel remotely.

M2M’s software modem currently supports DLS 5, DLS 2002, Compass 2.0, DL900, DLX900 software.

Note: If the communicator is a MN Series one, then an additional M2M-RNGR ringer module is needed.
The MQ communicators have built-in ringer.

Note: All six wires must be connected between the MN Series communicator and the MNO1-RNGR ringer module.
Wiring the panels Qutput and Input (0 and W at MNO1-RNGR) is not required for the operations of the software modem.
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ab Start by clicking here to download the installation file

Step 1
Launch the “M2MUDLModemSetup.msi” installation file by double clicking on it. (Pic. 1)

Note: If Microsoft Defender tries to prevent the installation, go through “More info” > “Run anyway".

Press “Next” to proceed. (Pic. 2) , .
Pic. 1 Pic. 2

& M2M UDL Modem X
Welcome to the M2M UDL Modem Setup Wizard Dl
The installer will guide you through the steps required to install M2M UDL Modem on
your computer.

4|

e /AF G: This program is p by ight law and ir
3-:‘: treaties. Unauthorized ication or distribution of this program, or any portion of it, may
resultin severe civil or criminal penalties, and will be ited to the i extent

VZMUDIMG: possible under the law.

demSetipim

]
ji&: M2M UDL Modem
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http://m2mos.com/modem/
http://m2mos.com/modem/

M:2M

A9 SIMPLICITY.
APPLIED.

Step 2
Press “Next” without changing the preconfigured installation location. (Pic. 3)

Then start the installation. (Pic. 4)

Software Modem Installation

Note: Do not stop an installation in progress.

Pic. 3

i& M2M UDL Modem

Select Installation Folder

7,

The installer will install M2M UDL Modem to the following folder.

To install in this folder, click "Next™. To install to a different folder, enter it below or click
“Browse".

Folder:

CAProgram Files (x86)\M2M Services\M2M UDL Modem\ Browse...

Disk Cost...

Install M2M UDL Modem for yourself, or for anyone who uses this computer:

(®) Everyone
O Justme

Pic. 4

{5 M2M UDL Modem

Confirm Installation

The installer is ready to install M2M UDL Modem on your computer.

Click "Next" to start the installation.

(L [
s M2M UDL Modem
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Step 3
After the installation is complete, press the “Close” button to exit the wizard. (Pic. 5)
A shortcut with a name “M2M UDL modem” should appear on your desktop.

Open the program by double clicking on it. (Pic. 6)

Pic. 5 Pic. 6

Start the M2M UDL Modem appli

Installation Complete

M2M UDL Modem has been successfully installed.

Click "Close™ to exit.

|,.':—J M2M UDL Modem
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Step 4 Pic. 7

Enter your dealer/installer credentials. (Pic. 7)

They are the same as the ones you use for the M2M administrative portal.

Step 5

You must select two COM ports that will be used for the M2M
software modem the first time you log into the program. The
“Modem COM port” configuration must be also set up into DSC,
Honeywell and NX (Interlogix / GE) UDL software as modem.

Please select the COM ports for your M2M UDL Modem

i = B
Note: The “Internal COM port” you set must be reserved only for . .
the M2M software modem use! e

Note: The selected COM ports in Pic.8 are just an example.

However, by default COM9 is set, as some of the softwares for UDL
do not support ports above 10th.

After selecting the two ports, press “OK” to create the virtual pair
and then open the modem.
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Step 6
Navigate to the dropdown menu and select the desired panel type. (Pic. 9) | Note: Ifa COM port change is needed, press “SETTINGS”
Press “CONNECT” to start the software modem's session. (Pic. 10) and change it. To do it the modem has to be
, disconnected.
Open the manufacturer’s panel software.

Note: If you use NX (Interlogix / GE) panels you have to go through Steps 7 to 11 as well.
If you use Honeywell or DSC panels no further steps are required.

Pic. 9 Pic. 10

~. COM9 - M2M UDL Modem 1.0.14.85

~. COM9 - M2M UDL Modem 1.0.14.85

"‘I CONNECT | |B) SETTINGS

Panel: |DSC v counecrgma SETTINGS
)

--- Program started at 04/06/2020 11:15:29 ---

k 06/2020 11:15:29 ---

ts COM9 (Application) and COM10 (internal)
n serial port to COM9

M2 UDL Modem is using ports COM9 (Application) and COM10 (internal)
Please set your application serial port to COM9
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Step 7 - NX (Interlogix / GE) panels only Pic 11 [l < oescrimon =

Control panel

Open “Device Manager”. (Pic. 11) 5 et

£ Enroll in MDM only

Search the web

Step 8 - NX (Interlogix / GE) panels only Slsamenm s
Select “Ports (COM & LPT)” or “Yirtual Serial Ports” from the list of items. (Pic. 12)
Navigate to “Action” and select “Add legacy hardware”. (Pic. 13)

*  Devices Online Manuals

£ device mapao

Pic. 12 Pic. 13

g Device Manager 3¢ o Device Manager - o X
File Action View Help | File Action View Help
e F ‘] n ol [;] = Scan for hardware changes
s Disk drives A | [ > Add legacy hardware h ~
I: ::::'Zr:dap'e“ Devices and Printers
## Human Interface Devices Properties

*® IDE ATA/ATAPI controllers Hel
% Imaging devices i

B3 Intel(R) Dynamic Platform and Thermal Framework —_————————

= Keyboards =2 Keyboards

. Mice and other pointing devices . Mice and other pointing devices
Bl Monitors B8 Monitors
& Network adapters & Network adapters
K7 Other devices &7 Other devices
» = Print queues » [ Print queues
= Printers = Printers
1 Processors [ Processors
B9 Security devices |7 Security devices
> [ Sensors 3 Sensors
¥ software components ¥ Software components
B Software devices B software devices
& Sound, video and game controllers i Sound, video and game controllers
S Storage controllers » S Storage controllers
Em System devices m System devices
> § Universal Serial Bus controllers
l W Virtual Serial Ports (Eltima Softwate) l > i Virtual Serial Ports (Eltima Softwate)
0 WSD Print Provider

Add a legacy (non Plug and Play) device to the computer.
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Add Hardware

Welcome to the Add Hardware Wizard

Step 9 - NX (Interlogix / GE) panels only Pic. 14
In“Add Hardware Wizard” press “Next”. (Pic. 14)

This wizard helps you install driver software to support older
devices that do not support Plug-and-Play and which are not
automatically recognized by Windows.

You should only use this wizard if you are an advanced user or
you have been directed here by technical support.

Mark “Install the hardware that I manually select from a list (Advanced)”
and press “Next”. (Pic. 15)

A If your hardware came with an installation CD, it is
recommended that you click Cancel to close this wizard
and use the manufacturer’s CD to install this hardware.

Then select “Modems” and press “Next”. (Pic. 16)

To continue, click Next.

<Beck Cance

Pic. 15 Pic. 16

Add Hardware Add Hardware

The wizard can help you install other hardware From the list below, select the type of hardware you are installing

The wizard can search for other hardware and automatically install it for you. Or, if you know If you do not see the hardware category you want, click Show All Devices.
exactly which hardware model you want to install, you can select it from a list.

Common hardware types:

£ IMemory technology devices ~
H Miracast display devices

vices

Multi-port serial adapters
¥ Network adapters
& OPOS Legacy Device
L 1PCMCIA adapters
{#Hl Perception Simulation Controllers

Bl naasalilo Do casa

What do you want the wizard to do?
O Search for and install the hardware automatically (Recommended)

l (®|Install the hardware that | manually select from a list (Advanced) ] ]

<Back | Next> N Cancel <Back | Next> Cancel

i
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Step 10 - NX (Interlogix / GE) panels only
Mark “Don’t detect my modem; | will select it from a list”, then press “Next”. (Pic. 17)

Afterwards, select “Standard Modem Types’, select “Standard 300 bps Modem®, and press “Next”. (Pic. 18)

Pic. 17 Pic. 18

Add Hardware Wizard Add Hardware Wizard

Install New Modem Install New Modem
Do you want Windows to detect your modem?

Select the manufacturer and model of your modem. If your modem is not listed, or if you have

Ricie Bl iow i Celect ot noceip gRette e an installation disk, click Have Disk.

continuing, you should:

1. If the modem is attached to your
computer, make sure it is tumed on.

2. Quit any programs that may be using

the modem.
Click Next when you are ready to continue. Manufacturer Models &
(Standard Modem Types)
[ [v [Don't detect my modem; | will select it from a list, ] tandard Cell Phones
[ = Standard 2400 bps Modem W
[5J This driver is digitally signed. Have Disk...

Tell me why driver signing is important

_— —
< Back | Next > %| Cancel < Back Cancel
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Step 11 - NX (Interlogix / GE) panels only
Mark “Selected ports”. (Pic. 19)

Select “COMxx” where COMxx is the same COM port, as the one you selected in “Step 5" as a“Modem COM port”. (Pic. 19)

Press “Next” to proceed (Pic. 19) and then press “Finish” to finish the installation of the modem. (Pic. 20)

Pic. 19 Pic. 20

Install New Modem Install New Modem
Select the port(s) you want to install the modem on. Modem installation is finished!

You have selected the following modem:

‘Your modem has been set up successfully.
lStandard 300 bps Modem

If you want to change these settings, double-click the
Phone and Modem Options icon in Control Panel, click the
Modems tab, select this modem, and then click Properties.

On which ports do you want to install it?

_@ Selected ports
COM9 k

<Back Cancsl <Back ] Cancel

11 of 14



M2M

SERVICES

SIMPLICITY.
APPLIED.

REMOTE UPLOAD/DOWNLOAD
SOFTWARE CONFIGURATION MANUAL FOR COMPASS

Configuration steps to enable upload/download via M2M-Modem
1. Plugin the M2M-Modem-Vista in a USB port on the PC with the Compass software.
2. Goto Control Panel = Device Manager > PORTS to find out which is the COM port number
assigned to the M2ZM-Modem
3. Open Compass > Home Page > Modems
Configure the following settings in Communication Settings dialog:
* 5o to “Configure COM ports” — Select the COM port of the Modem from the
dropdown Click on Add and Close
In “Standard Modems” select Ademco CIA 2400
Check the “Touch Tone” checkbox
Click on OK to apply the changes.

4. Usa the Serial Number of the cellular communicator instead of a phone number for each
account.
Customer Details = Panel Phone Number

Proceed with the programming as if you were connecting via the POTS line.

NOTE: Before you start a new communication session to specific panel make sure that the
following settings are selected in the “Communications” dialog:

*  The correct COM port is selected in “Comm Port” dropdown

*  “Initiate From’ should be set to “PC”

+  “Answering Machine Defeat” should be unchecked

¢  The Serial Number of the cellular communicator is set instead of 2 phone number

Troubleshooting the panel configurations for the remote upload/download
If you have issuas with the remote upload/download, check the following settings of the panal:
*+  “Rings Count for Downloading” should be set to 1. This will disable the “Answering
Machine Defeat”
*  “Call Back"” should be disabled (if this configuration is available for the specific panel
model)
+  The “CSID Code” should be the same as the one set in the Compass software (if this
configuration is available for the specific panel model}
¢ The “Account number” of the panel should be the same as the one sat in the Compass
software

Software Modem Installation
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REMOTE UPLOAD/DOWNLOAD
SOFTWARE CONFIGURATION MANUAL FOR DL900

Installing the M2M-Modem
1. Plugin the M2M-Modem-GE in a USB port on the PC with the DL900 software.
2. Goto Control Panel > Device Manager > Action > Add legacy hardware = Follow the installation
wizard:
#  Second step —select “Install the hardware that | manually select from a list”
*  Third step — “Common hardware types” scroll down and select “Modems”
*  Forth step — check “Don't detect my modem” checkbox
#  Fifth step — select “Standard300 bps Modem”
*  Sixth step —select “Selected ports” and chose the appropriate COM port
Go to Control Panel > Device Manager > PORTS to find out which is the COM port
number assigned to the M2M-Modem
Press Finish to complete the installation.

Configuring DL900 to enable upload/download via M2M-Modem
1. Open DL900 > Home Page > Program > Setup > Modem sefup
and configure the following settings:
#  Scroll down to find “Hayes Smartmodem 300" as a string description.
*  Select the installed “Standard 300 bps Modem” in “Connect using” dropdown
*  Choose Tene in “Dial type” dropdown
* Choose 300 in “Port baud rate” dropdown
Click OK to Save the configuration.
2. Use the Serial Number of the cellular communicator instead of a phone number for each
account.
3. Change the phone number/s by following the steps below:
Option 1:
Home Page > View> Customers = List
Set the Serial numbers of the cellular communicator in “Panel phone” column on each
corresponding row/account.
Click on Save to apply the changes.
Option 2:
Home Page = View: Customers = Single customer
Find the specific account and set the Serial numbers of the cellular communicator in Panel phone
field.
Click on Save to apply the changes.

Troubleshooting the panel configuration
If you have issues with the remote upload/download, check the following settings of the panel:
*  “Answering Maching Defeat” should be disablad
s “Call Back” should be disabled
+  The "Download Access Code” of the panel should be the same as the one setin the DL900
*  “Number of Rings to Answer” should be set to 1

Software Modem Installation
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REMOTE UPLOAD/DOWNLOAD
SOFTWARE CONFIGURATION MANUAL

DLS 5 REMOTE PROGRAMMING SOFTWARE

Configuration steps to enable upload/download via M2M-Modem

1. Plugin the M2M-Modem-D5C in a USE port on the PC with the DLS software.

2. Goto Control Panel > Device Manager = PORTS to find out which is the COM port number
assigned to the M2M-Modem

3. Open DLS 5 > Home Page > Tools > Modem Manager Configuration > Add New Modem of type
MD-12

4. Select the new modem and configure following settings in the drop-down menus:
*  PORT - Select the COM port of the Modem
*  Call Preferences — Select “Disable Dial and Busy Tone Detection”
+  Dialing Method — Select DTMF Dialing

5. Click OK to close Modem Configuration.

Configurations when adding new account

1. Goto Home Page = File > New Account

2. Configura the following settings:
*  Connection Type — PSTN
*  Phone Number — Use the Serial Number of the MiNi01-4G instead of 2 phone number
*  Uncheck “Double Call” checkbax

3. Click Craate to Save the Account.

Editing Existing Account

1. Right-click on the Account = Go to Properties > Panels Modules = Panel = PSTN/Existing Phone
Number:

2. Configure the following settings:
*  Phone Number — Use the Serial Number of the MiNI01-4G instead of a phone number
*  Uncheck “Double Call Enable” checkbox

3. Click Save to apply the changes.

Proceed with the programming as if you were connecting via the POTS line.

Troubleshooting the panel configurations for the upload/download
If you have issues with the remote upload/download, check the following settings of the panel:
+  “Double Call” should be disabled
s “Call Back” should be disabled
+  “Baud rate” should be set to300dps (if this configuration is available for the specific panel)
s The “Panel ID Code” should be the same as the one set in the DLS software
*  The “DLS Downloading Access Code” of the panel should be the same as the one set in the
DL3 software
*  “Number of Rings To Answer On" should be setto 1

Software Modem Installation

DLS 2002 REMOTE PROGRAMMING SOFTWARE

Configuration steps to enable upload/download via M2M-Modem
1. Plugin the M2M-Modem-DSC in a USB port on the PC with the DLS software.
2. Goto Control Panel = Device Manager = PORTS to find out which is the COM port number
assigned to the M2M-Modem
Open DLS 2002 = Home Page > Tools = Modem Configuration
Tab “General” = Add
In Add Modem dropdown select “Digital Security Controls MD12" > OK to close
. Select “Digital Security Controls MD12" = Open Propertias
General tab:
®  PORT - Select the COM port of the Modem (you can find the PORT name it in Control Panel =
Device Manager > PORTS)
*  Dialing Method — TONE
Connection tab:
®  (Call Preferences — Disable
*  Uncheck “Automatic Radial” checkbox
7. Click OK to Save the settings and close the dialog.
8. Gototab“Outgoing” = Select “Digital Security Controls MD12"
9. Click OK to close Madem Configuration.

oW

Configurations when adding new account
1. GotoHome Page = File » New Account
*  Panel Phone Number — Use the Serial Number of the MiNi01-4G instead of a phone number

Proceed with the programming as if you were connecting via the POTS line.

Troubleshooting the panel configurations for the upload/download
If you have issues with the remote upload/download, check the following settings of the panel:
*  “Double Call" should be disabled
e “Call Back” should be disabled
*  “Baud rate” should be set to300dps (if this configuration is available for the specific panel)
®  The “Panel ID Code” should be the same as the one set in the DLS software
*  The “DLS Downloading Access Code” of the panel should be the same as the one set in the
DLS software
& “Number of Rings To Answer On"” should be set to 1
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“No UDL License” Error Message

If you receive the error message “Error: Login user has no UDL licenses” (Pic.21), then you do net have a license for the M2M software
modem.

In such case you need to contact your M2M products’supplier.

Pic. 21

< COMY - M2M UDL Madern 1.0.14.85

Pane | DSC e CONNECT SETTINGS

== Program started at 67172020 Z:38:18 PM ===

HIM UDL Modem is uaing ports COMYS (Application) and COMID (inter

r application serial port to COMS
Hoden state: ATHode

260719 : ERROH: Login user has no UL licenses
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CONFIGURATION AND REQUIREMENTS

Mandatory configurations for your modem:

v" Disable Dial and Busy tone detection

v Set”Number of Rings to answer”to 1

v" Dialing Method to be “DTMF" or “Touch Tone”

Requirements for the installation are:
v" Windows 7 or later

v' 64-bit operational system

v" NET4.0 or above

Honeywell software Requirements:

“Account Code” should match the panels

“Initiate from PC" should be applied

“Answering Machine Defeat” should be unmarked
“Call Back” should be disabled

“CSID Code” should match the panels

The serial number of the device must be set as phone
number

DN NI NI NI N

DSC software Requirements:

Disable “Double Call”

Disable “Call Back”

Connection type should be “PSTN”

“Panel ID” code should match the panels

“DLS Downloading Access Code” should match the panels
The serial number of the device must be set as phone
number

DI N NI NI N

NX (Interlogix / GE) software Requirements:

Steps 7 through 11 must be completed

“Answering Machine Defeat” should be disabled

“Call Back” should be disabled

“Download Access Code” should match the panels
The serial number of the device must be set as phone
number

DN NI N NN
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M2M Services

support@mz2mservices.com
sales@m2mservices.com
800-403-7029

A full list of the supported panels can be found at:

Compatibility List of M2M Communicators
https://support.m2mservices.com/files/M2M Compatibility List.pdf
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